[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Please Help With Dual Head



I experienced the random lockups of the radeon driver and have found 2
solutions.

1. Use the ati proprietary fglrx driver & kernel module. Instructions
are on http://rpm.livna.org.

2. Install the xorg version that is in fedora's rawhide development server.

yum --enablerepo=development install xorg-x11-drv-ati

That brings in a whole gob of new xorg packages, but after installing
that, there were no more random system lock ups.

If you still have trouble configuring, contact me privately and I can
email you a working xorg.conf if you like.

On 5/26/06, cromworshipper-fedorastuff yahoo com
<cromworshipper-fedorastuff yahoo com> wrote:

--- Troy Bull <troybull lists gmail com> wrote:

> Greetings:
>
> I recently upgraded my os (a clean install) to Fedora Core 5, and I was
> excited to see the support for Dual Head built into the configuration
> utility.  I am having a problem getting it setup correctly.  What I want
> is to extend my desktop onto my second monitor.  I went through the
> System->Administration->Display utility and can't make it work.  I will
> describe what is happening.
>
> I have 2 identical monitors and a Radeon X600 PCIE card.  When I boot to
> windows the setup works so it is plugged in correctly.  The monitors are
> connected via the digital hookup.
>
> On my left monitor I have a desktop.  Then on my right monitor I have a
> ghosted image from the left monitor.  If I try to click on the left
> monitor it doesn't work (I can move the mouse onto screen1 by going off
> the right edge of screen 0.  I noticed by looking at the workplace
> switcher I actually have the wide desktop.  I can move windows on and
> off the part which lies underneath the ghosted image of screen1.
>
> So in short, everything is correct except Screen1 shows an image of
> Screen0 instead of the desktop which is really there.
>
> I am a bit frustrated as I have been tinkering with xorg.conf and can't
> make it work.  This used to work so I feel like it still should, if
> anyone could give me some tips or something I would greatly appreciate it.

Troy,

Though I didn't go over your xorg.conf file too closely, I don't think that's
your problem.  The problem is in the Xorg7 Radeon driver.  There is an update
posted at
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/5/i386/xorg-x11-drv-ati-6.5.8.0-1.i386.rpm.

I think you can install it by typing something like:

sudo yum --enablerepo=updates-testing update xorg-x11-drv-ati

BEWARE!  On some ATI boards, this update will lock up your machine randomly.
There's already a bug filed on this that hasn't seen any activity for a
while:
https://bugs.freedesktop.org/show_bug.cgi?id=5781
This is what I'm experiencing.
A week ago, I did a complete checkout and build to see if CVS HEAD fixed this
problem.  I found that it made no difference on my T30.

Good luck.

John

--
fedora-test-list mailing list
fedora-test-list redhat com
To unsubscribe:
https://www.redhat.com/mailman/listinfo/fedora-test-list



--
Paul E. Johnson
Professor, Political Science
1541 Lilac Lane, Room 504
University of Kansas


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]