[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpmlib(PayloadIsXz) <= 5.2-1 is needed by ?????




--- On Mon, 8/10/09, Michael Schwendt <mschwendt tmp0701 nospam arcor de> wrote:

> From: Michael Schwendt <mschwendt tmp0701 nospam arcor de>
> Subject: Re: rpmlib(PayloadIsXz) <= 5.2-1 is needed by ?????
> To: fedora-test-list redhat com
> Date: Monday, August 10, 2009, 11:53 AM
> On Mon, 10 Aug 2009 09:44:51 -0700,
> Jesse wrote:
> 
> > On Mon, 2009-08-10 at 09:32 -0700, Antonio Olivares
> wrote:
> > >
> ================================================================================
> > >  Package       
> Arch  Version           
>                
> Repository
> > > Size
> > >
> ================================================================================
> > > Updating:
> > >  rpm         
>   i686  4.7.1-3.fc12
> > > updates-testing  826 k
> > 
> > fedora-release defines your Fedora version as "12",
> therefor enabling
> > updates-testing is actually just enabling yet another
> repo that points
> > to rawhide, eg the updates-testing for Fedora 12 is...
> rawhide right
> > now.
> 
> Unfortunate, because that means the work-around at
> 
>   http://rawhidewatch.wordpress.com/2009/07/31/unable-to-update-to-rawhide-rpmlibpayloadisxz/
> 
> doesn't work for "an older rawhide" as explained here:
> 
> | However, folks upgrading from Fedora 11 or from an older
> rawhide may
> | need to manually workaround this issue using the
> following commands:
> |
> | yum --enablerepo=updates-testing update rpm
> 
> Conclusively, the only work-around for "an older rawhide"
> is _again_ to
> fetch the fc11 RPM from updates-testing manually or by
> modifying the .repo
> file for updates-testing or to download the files from
> within koji.
> 
> https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7986
>  => http://koji.fedoraproject.org/koji/search?terms=rpm-4.7.1-1.fc11&type=build&match=glob
> 
> -- 

Thanks for trying to help me, but unfortunately the above does not work

[root localhost Download]# rpm -Uvh rpm-4.7.1-1.fc11.i586.rpm 
error: Failed dependencies:
	liblzma.so.0 is needed by rpm-4.7.1-1.fc11.i586
	rpm = 4.7.0-8.fc12 is needed by (installed) rpm-libs-4.7.0-8.fc12.i586
	rpm = 4.7.0-8.fc12 is needed by (installed) rpm-python-4.7.0-8.fc12.i586
	rpm = 4.7.0-8.fc12 is needed by (installed) rpm-build-4.7.0-8.fc12.i586
[root localhost Download]# rpm -Uvh rpm-4.7.1-1.fc11.i586.rpm --nodeps
Preparing...                ########################################### [100%]
   1:rpm                    ########################################### [100%]
[root localhost Download]# yum update yum -y
Loaded plugins: dellsysidplugin2, refresh-packagekit, refresh-updatesd
rawhide/metalink                                          |  11 kB     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package yum.noarch 0:3.2.23-13.fc12 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================
 Package       Arch             Version                  Repository         Size
=================================================================================
Updating:
 yum           noarch           3.2.23-13.fc12           rawhide           586 k

Transaction Summary
=================================================================================
Install       0 Package(s)
Upgrade       1 Package(s)

Total size: 586 k
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(PayloadIsXz) <= 5.2-1 is needed by yum-3.2.23-13.fc12.noarch
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])
[root localhost Download]# yum update rpm
Loaded plugins: dellsysidplugin2, refresh-packagekit, refresh-updatesd
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package rpm.i686 0:4.7.1-3.fc12 set to be updated
--> Processing Dependency: liblzma.so.0 for package: rpm-4.7.1-3.fc12.i686
--> Running transaction check
---> Package xz-libs.i686 0:4.999.8-0.9.beta.20090804git.fc12 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================
 Package     Arch     Version                                  Repository   Size
=================================================================================
Updating:
 rpm         i686     4.7.1-3.fc12                             rawhide     826 k
Installing for dependencies:
 xz-libs     i686     4.999.8-0.9.beta.20090804git.fc12        rawhide      90 k

Transaction Summary
=================================================================================
Install       1 Package(s)
Upgrade       1 Package(s)

Total size: 916 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(PayloadIsXz) <= 5.2-1 is needed by xz-libs-4.999.8-0.9.beta.20090804git.fc12.i686
rpmlib(PayloadIsXz) <= 5.2-1 is needed by rpm-4.7.1-3.fc12.i686
rpm = 4.7.0-8.fc12 is needed by (installed) rpm-libs-4.7.0-8.fc12.i586
rpm = 4.7.0-8.fc12 is needed by (installed) rpm-python-4.7.0-8.fc12.i586
rpm = 4.7.0-8.fc12 is needed by (installed) rpm-build-4.7.0-8.fc12.i586
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])
[root localhost Download]# rpm -qa rpm*
rpm: error while loading shared libraries: liblzma.so.0: cannot open shared object file: No such file or directory
[root localhost Download]# ldconfig
[root localhost Download]# yum update xz-libs
Loaded plugins: dellsysidplugin2, refresh-packagekit, refresh-updatesd
Setting up Update Process
Package(s) xz-libs available, but not installed.
No Packages marked for Update
[root localhost Download]# yum install xz-libs*
Loaded plugins: dellsysidplugin2, refresh-packagekit, refresh-updatesd
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package xz-libs.i686 0:4.999.8-0.9.beta.20090804git.fc12 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================
 Package     Arch     Version                                  Repository   Size
=================================================================================
Installing:
 xz-libs     i686     4.999.8-0.9.beta.20090804git.fc12        rawhide      90 k

Transaction Summary
=================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total size: 90 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
rpmlib(PayloadIsXz) <= 5.2-1 is needed by xz-libs-4.999.8-0.9.beta.20090804git.fc12.i686
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'])


I try and I try and I get back the same :(

Regards,

Antonio 


      


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]