[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: what USB-2 CF reader is alleged to work?



On Sat, 08 Jan 2005 04:45:58 -0800, Jamie Zawinski <jwz jwz org> wrote:

> Are any of you running FC3 and able to get pictures off of a
> CompactFlash card at USB-2 speeds?  If so, what CF reader are 
> you using?  Because I want to go out and buy one of those.
>
> The set of readers I have tried recently are:
>   - SanDisk ImageMate SDDR-31 USB 1.0 reader;

I use SDDR-31 successfuly since 2001, it's a great device with [almost]
no serious firmware problems which plague this kind of peripherals.

> All of them do this when I plug them in (card present or not):
> 
>     usb 5-1: new full speed USB device using address 52
>     usb 5-1: device not accepting address 52, error -71
>     usb 5-1: new full speed USB device using address 53
>     usb 5-1: device not accepting address 53, error -71

This is not good, because -71 is a low-level protocol error. Usually it
is called by things like a bitstuffing violation, a missing token, etc.
I cannot speculate what causes it, but every component has to be excluded
by replacement. We can exclude readers now, so it leaves motherboard
chips and traces, cables, possibly a hub, and most especially any power
supplies involved. Sometimes it happens when people connect external VGA
to a laptop, go figure! (I am not saying this is your problem, obviously).
I know who I am dealing with, Jamie, but for the list archives: DO NOT
exclude two articles at a time. If you replace the laptop, leave all cabling,
hubs, and the reader, in place.

To be frank, it is possible for the software to report -71 for a bad
reason, when it is confused. Once we excluded everything else, with
the computer itself, it's time to look at UHCI root hub handling.
We'll take it from there.

> "Eratically" means that generally they would work immediately after
> I rebooted the machine, and I could plug/unplug them right after
> that, and they'd continue working; but if I tried to use them again
> a few hours later, the only way to make them work would be to reboot
> again.  No amount of rmmod would bring joy (though some would bring
> complete wedgedness.)

This is very interesting, but I don't think I can act upon this section
of your report, especially that it appears to relate a past experience.
Let's concentrate on -71s.

BTW, I should note that it is possible to use a passive PCMCIA-CF adapter.
I have one of those as well, and it works great. The only reason I used
SDDR-31 is that my only PC Card slot was often used by a wireless card.
Eventually I got used to it. Also, in older distros and kernels it was
required to stop and start pcmcia services when you plug the thing, and
USB always was 100% hotplug, at least in theory.

-- Pete


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]