[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: further package removals/potential package removals



On Sat, 2005-01-22 at 22:16 -0600, Chris Adams wrote:
> 
> nautilus has an explicit dependency in the spec file on gnome-vfs2-smb.
> It does not have any apparent dependency on libsmb.so that is provided
> by gnome-vfs2-smb (nothing seems to have such a dependency).  If I don't
> have any need to browse Windows networks, why do I need the software
> installed?

libsmb.so is dlopen'd, so no ldd dependency.

> Features are great; _required_ features are not.

The reason for a Requires here (and in similar cases) 
is to suck in gnome-vfs2-smb when anaconda upgrades 
a system.

Comes up with some package in most releases, and there
are a fair number of Requires: that exist purely for 
that reason.

Havoc



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]