[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: further package removals/potential package removals



On Sun, 2005-01-23 at 05:31 +0100, Enrico Scholz wrote:
> Yes, the stupid kernel packaging which brings 30 MB of bloat into / is a
> problem also. But nevertheless, the deps should be cut. A candidate would
> be 'pam' which brings 'glib2' in, or all the packages with 'Requires:
> kernel>=2.6' which should be either removed or rewritten to 'Conflicts:
> kernel<2.6'.

The problem is pam_console (and maybe others) modules (which are by
default configured to be used) require glib2. And I don't see any
possibility to make the pam_console optional. So you can tune your
minimum install so the pam_console is removed from all /etc/pam.d/...
configs and then you can remove glib2. Or you can write a patch for all
pam modules in redhat which use glib2 which replace the functionality
provided by glib2 by another means and if it's good it will be applied.
But I won't write it as I have many more useful things to do.

-- 
Tomas Mraz <tmraz redhat com>


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]