[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RFC: Soname in rpm name



On Tue, 25 Jan 2005 08:53:17 -0500, seth vidal wrote:

> 
> > Sounds interesting. On the other hand, maybe we could do it manually (from a
> > packager's point of view) : if you package library foo, and you know that
> > version 0.1 is not supported anymore (noone knows that better than you
> > since you maintain it), you can add an Obsoletes tag to your libfoo5
> > package, and force the removal.
> > Would that solve Jeff's issue ?
> > 
> 
> Obsoletes should be used when a package changes name. Not when someone
> thinks a new version gets rid of an old version.

Where are such strict semantics of the "Obsoletes" field defined?

Isn't it rather free to use? As in "we don't need that package
any longer, it's obsolete and can be erased"?

If, for instance, functionality of one package is supplied by another
package, that's not a rename, but a relocation of package
capabilities. Package "foo" would "Obsoletes: bar <= 1.0". If an old
library API/ABI is not used anymore and hence considered obsolete, a
new version of the library could "Obsolete: libfoo <= 0.9" just fine.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]