[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

plplot linked incorrectly [was: multi-lib brokenness?]



Hello Orion:

On Wed, Aug 08, 2007 at 12:19:00PM -0600, Orion Poplawski wrote:
> I got this from the buildsys.  Looks like a multi-lib of some kind. 

> 	plplot - 5.7.3-3.fc8.i386 requires libtk.so
> 	plplot - 5.7.3-3.fc8.i386 requires libtcl.so
...
> 	plplot-tk - 5.7.3-3.fc8.i386 requires libtk.so
> 	plplot-tk - 5.7.3-3.fc8.i386 requires libtcl.so

no, this is not multilib problem.

Your build is not linked correctly; ldd reveals that the binaries are
linked against "libtcl.so" and "libtk.so" instead of "libtcl8.4.so"
"libtk8.4.so".

The build environment contained broken versions of tcl and tk,
tk-8.4.15-1.fc8  and  tcl-8.4.15-1.fc8 .
I have just filed the bugs:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=251410
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=251411

> Anything I need to do?

As soon as these bugs are fixed (or the broken rpms are untagged), you
have to rebuild plplot.

Hope this helps,
	Stepan Kasal


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]