[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: strange failure for dependency against libdb-4.5.so



On 08/17/2007 10:30 AM, Jindrich Novy wrote:
> Hi,
> 
> On Fri, Aug 17, 2007 at 11:50:00AM +0900, Mamoru Tasaka wrote:
>> Hi.
>>
>> Now I am checking ice review request (bug 234612) and I tried
>> to rebuild ice on koji scratch build. However I met with a
>> strange buildroot error:
>>
>> ---------------------------------------------------------------
>> Executing /usr/sbin/mock-helper yum --installroot /var/lib/mock/dist-f8-build-32623-4599/root resolvedep  'ant-nodeps' 'mono-core' 'php-devel' 'ruby-devel' 'bzip2-devel' 'python-devel' 'expat-devel' 'java-devel >= 1.5.0' 'openssl-devel' 'ruby-libs' 'ant' 'jpackage-utils' 'php' 'ruby' 'db4-devel' 'db4-java'
>>
>> <snip>
>>
>> Executing /usr/sbin/mock-helper yum --installroot /var/lib/mock/dist-f8-build-32623-4599/root install  'ant-nodeps' 'mono-core' 'php-devel' 'ruby-devel' 'bzip2-devel' 'python-devel' 'expat-devel' 'java-devel >= 1.5.0' 'openssl-devel' 'ruby-libs' 'ant' 'jpackage-utils' 'php' 'ruby' 'db4-devel' 'db4-java'
>> Error: Missing Dependency: libdb-4.5.so is needed by package ruby-libs
>> Error: Missing Dependency: libdb-4.5.so is needed by package httpd
>> Error: Missing Dependency: libdb-4.5.so is needed by package httpd-tools
>> Error: Missing Dependency: libdb-4.5.so is needed by package apr-util
>> Cleaning up...
>> ----------------------------------------------------------------
>> http://koji.fedoraproject.org/koji/taskinfo?taskID=105168
>>
>> What is happening here? I don't see these unresolved dependencies
>> on daily rawhide report and when I tried to install these 4 packages
>> everything seems okay.
> 
> 
> db4 was updated recently to 4.6.18, and older db-4.5.20 was moved to compat-db, so
> if you need libdb-4.5.so, add dependency on compat-db.

Hmmm. That's mysterious... mock/yum has pulled in compat-db 4.5.20 in
the buildroot (that's fine), but then it gave up, believing that ruby,
httpd and apr need libdb-4.5.so; Available but for some reason not seen
by yum!?

Can you retry?

-of



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]