[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Yum exploding



Not sure this is know didn't see anything relevant on bugzilla, should I
open a new report there?

(note: a following yum update is in progress and does seem to work
correctly)

# yum update fedora-ds-base
Setting up Update Process
development               100% |=========================| 2.1 kB
00:00
primary.sqlite.bz2        100% |=========================| 5.2 MB
00:10
development-debuginfo     100% |=========================| 1.9 kB
00:00
Resolving Dependencies
--> Running transaction check
---> Package fedora-ds-base.x86_64 0:1.1.0-1.2.fc8 set to be updated
---> Package fedora-ds-base.i386 0:1.1.0-1.2.fc8 set to be updated
--> Processing Dependency: libdb-4.6.so()(64bit) for package:
fedora-ds-base
--> Processing Dependency: fedora-ds-base = 1.1.0-0.3.20070720.fc8 for
package: fedora-ds-base-devel
--> Processing Dependency: libdb-4.6.so for package: fedora-ds-base
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package db4.i386 0:4.6.18-1.fc8 set to be updated
---> Package db4.x86_64 0:4.6.18-1.fc8 set to be updated
---> Package fedora-ds-base.x86_64 0:1.1.0-1.2.fc8 set to be updated
---> Package fedora-ds-base.i386 0:1.1.0-1.2.fc8 set to be updated
---> Package fedora-ds-base-devel.x86_64 0:1.1.0-1.2.fc8 set to be
updated
--> Processing Dependency: libdb-4.5.so()(64bit) for package: bind
--> Processing Dependency: libdb-4.5.so()(64bit) for package: python
--> Processing Dependency: libdb-4.5.so for package: apr-util
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 135, in main
    (result, resultmsgs) = base.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 540, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 885, in
resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processReq(dep,
prcoformat_need)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 334, in
_processReq
    requirementTuple, errormsgs)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 469, in
_requiringFromInstalled
    return self._requiringFromTransaction(reqpkg, requirement,
errorlist)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 574, in
_requiringFromTransaction
    reqpkg = self.tsInfo.matchNaevr(name=name, ver=version,
rel=release)[0]
IndexError: list index out of range



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]