[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Ugly dependency checker



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jesse Keating wrote:
> On Tue, 21 Aug 2007 16:43:38 +0200
> Jeroen van Meeuwen <kanarip kanarip com> wrote:
> 
>> Right that I figured, but what I don't understand is it reports dkms
>> has missing requirement 'kernel-devel'.
> 
> Shot in the dark, you said arch i386, yet the kernel-devel package is
> i686.
> 
> 

Right, point taken. However, that doesn't apply to these:

package: Democracy - 0.9.5.1-8.fc7.i386 from fedora
  unresolved deps:
     firefox = 0:2.0.0.3
package: dbmail-sqlite - 2.2.4-4.fc7.i386 from fedora
  unresolved deps:
     dbmail = 0:2.2.4-4.fc7
package: gauche-gtk - 0.4.1-12.fc7.i386 from fedora
  unresolved deps:
     gauche = 0:0.8.10
package: libgeda-doc - 20070216-1.fc7.i386 from fedora
  unresolved deps:
     libgeda = 0:20070216-1.fc7
package: pcb-doc - 0.20060822-9.fc7.i386 from fedora
  unresolved deps:
     pcb = 0:0.20060822
[...snip...]
package: syncekonnector - 0.3.2-2.fc7.i386 from updates
  unresolved deps:
     libkonnector.so.0
     libksync.so.1
     libmultisynk.so.0
package: system-switch-java-gui - 1.0.0-1.fc7.noarch from fedora
  unresolved deps:
     system-switch-java = 0:1.0.0-1.fc7

Note that most of these packages come from the release tree (fedora
repository), and may have been updated meanwhile; dbmail-sqlite for
example doesn't get installed because it seems to have been integrated
into the dbmail package. Though, I specified -n so that repoclosure
would look at only the latest and greatest packages. Same goes for
system-switch-java-gui (in system-switch-java-1.1.0-2.fc7)

What is it I'm missing this time? What I wanted this to do is report to
me which of the most recent packages I could not install due to
dependency errors:

./depchecker.py --recent --efficient
Unresolvable dependency 'Requires: postfix EQ (u'0', u'2.4.3',
u'2.fc7')' for postfix-pflogsumm-2:2.4.3-2.fc7.i386 (from updates)
Unresolvable dependency 'Requires: postfix EQ (u'0', u'2.4.3',
u'2.fc7')' for sqlgrey-0:1.7.5-1.fc7.noarch (from fedora)
Unresolvable dependency 'Requires: postfix EQ (u'0', u'2.4.3',
u'2.fc7')' for postgrey-0:1.27-4.fc7.noarch (from fedora)

- --
Kind regards,

Jeroen van Meeuwen
- -kanarip

- --
http://www.kanarip.com/
RHCE, LPIC-2, MCP, CCNA
C6B0 7FB4 43E6 CDDA D258  F70B 28DE 9FDA 9342 BF08
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)

iD8DBQFGywoHKN6f2pNCvwgRArkLAJ0Zp4uHNIlF3c9hb/UI/C975YetzgCgn9z8
H3zNVcp+PxXx5AfXAest2NA=
=pNU9
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]