[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Problems upgrading to util-linux-ng in today's rawhide



Transaction Check Error:
file /usr/bin/i386 from install of util-linux-ng-2.13-0.57.fc8 conflicts with file from package setarch-2.0-4.fc7 file /usr/bin/linux32 from install of util-linux-ng-2.13-0.57.fc8 conflicts with file from package setarch-2.0-4.fc7 file /usr/bin/linux64 from install of util-linux-ng-2.13-0.57.fc8 conflicts with file from package setarch-2.0-4.fc7 file /usr/bin/setarch from install of util-linux-ng-2.13-0.57.fc8 conflicts with file from package setarch-2.0-4.fc7 file /usr/share/man/man8/setarch.8.gz from install of util-linux-ng-2.13-0.57.fc8 conflicts with file from package setarch-2.0-4.fc7

# rpm -q --obsoletes -p /data/sw1/fedora/development/i386/os/Fedora/util-linux-ng-2.13-0.57.fc8.i386.rpm
mount <= 2.11
losetup <= 2.11
schedutils <= 1.5
util-linux <= 2.13.0.51
setarch <= 2.0-4

# rpm -q setarch
setarch-2.0-4.fc7


Fails because setarch-2.0-4.fc7 > setarch-2.0-4 ? Should it just be "Obsoletes: setarch <= 2.0"? Looks like it's fixed with "Obsoletes: setarch <= 2.0-99", but I'm curious if the former would work. Seems best to avoid the release tag if possible.


--
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA/CoRA Division                    FAX: 303-415-9702
3380 Mitchell Lane                  orion cora nwra com
Boulder, CO 80301              http://www.cora.nwra.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]