[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: TeXLive is in rawhide



On Tue, 04 Dec 2007 21:33:35 +0100, Till Maas wrote:

> On Di Dezember 4 2007, Michael Schwendt wrote:
> 
> > Wrong. "Obsoletes: tetex <= 3.0" covers all releases including 3.0-50.fc9
> 
> Are you sure?

Yes, I am.

> Is there any documentation about this freely available?

I don't know that. Maybe one of the available books explains it.
It's common packaging knowledge, I believe.

If no specific release is asked for, it is not necessary anymore to
compare a package's %release value. Just as in

Requires: foo = 3.0

where your counter-example from below cannot be applied either, since
the "equal than" comparison works differently. Any release will match,
but you cannot "rpmdev-vercmp 3.0-1 3.0" to prove it.

> Because:
> $ rpmdev-vercmp 3.0 3.0-50.fc9
> 0:3.0-50.fc9 is newer

Strange example, because 1) you ask for a specific Release, and 2) it
compares the three EVR args differently. Your first EVR has Release
"None", which is mapped to something less than "not None" by RPM
implicitly to make comparison against Release 50.fc9 possible. Even
Release 0 is greater than "None". So, what value would you expect RPM
to substitute "None" with?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]