[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ANNOUNCE: bittorrent downgrade



Hi,

On Thu, 2007-03-01 at 09:00 +0000, Paul Howarth wrote:
> The bittorrent (and bittorrent-gui) package has been downgraded in the
> Extras development repo from version 5.0.5 to 4.4.0, due to 
> compatibility problems between the GUI and wxPython 2.8.x 

Thanks for ensuring that packages are usable; sometimes, sadly,
downgrading is the only option. Having said that...

> As this is still the development phase of the release, the downgrade was 
> done without an epoch bump, so:
> 
> MANUAL DOWNGRADE WILL BE NEEDED IF YOU USE THE bittorrent PACKAGE ON 
> RAWHIDE.

Can we please stop doing such things just because some people don't like
the Epoch being bumped? No-one have ever given good technical reasons
for this, only 

 - "it's ugly"; or
 - "some software is broken and don't know about Epoch"; or
 - "it's Rawhide, nobody should expect Rawhide to work"

To me it just seems, how shall I put it, non-constructive to put users
through a manual downgrade ordeal just to preserve one number that, for
the record, is meaningless already.

So, consider this a request for our various packaging committees to take
action and make our packaging guidelines reflect that we just don't do
things like this. Of course, if there exist technical reasons for not
bumping the Epoch, I don't pretend to be a packaging gure by any means,
that I'm not aware of I apologize for this noise.

Thanks.

      David "I have an OCD about other people's OCD's" Zeuthen



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]