[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: No shape and sync extensions in xorg?



Adam Jackson wrote:
On Sun, 2007-03-18 at 18:43 +0100, Dennis Jacobfeuerborn wrote:
Hi,
When I try to enable the desktop effects (ie. compiz) I get the following output:

[dennis nexus ~]$ desktop-effects
compiz: No sync extension
The program 'gnome-window-decorator' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
   (Details: serial 426 error_code 8 request_code 72 minor_code 0)
   (Note to programmers: normally, X errors are reported asynchronously;
    that is, you will receive the error a while after causing it.
    To debug your program, run it with the --sync command line
    option to change this behavior. You can then get a meaningful
    backtrace from your debugger if you break on the gdk_x_error() function.)
Xlib:  extension "SHAPE" missing on display ":0.0".

Your X config file has a Modules section, and it doesn't contain a line
for extmod.

Things are back to normal even though the Modules section still doesn't contain a line for extmod. Also I cannot reproduce this anymore under either nv or nvidia so I'm not really sure what has caused this in the first place. The only other change I made is I removed the "irqpoll" and "crashkernel" options from the kernel. The machine was unstable but a BIOS upgrade fixed this so they were no longer necessary (kdump complained that the kernel was unsupported anyway).

You claim to be using the nv driver later in the thread, but compiz
isn't going to work with that setup, period, because we don't have a DRI
driver for nvidia cards yet.

I am (was) switching between nvidia and nv in order to get beryl/compiz to work but right now I'm back to nv. I've played with that on my old box before and never got an error that these extensions are missing. The X error seems to be gnome-terminal specific and I still get this under beryl but not when I use x-term.

More likely you installed nvidia's closed
driver, and the install script for same added a Modules section that it
didn't need to.

It apparently added a Modules section with a Load "glx" command but why would that stop the extmod extension from auto-loading?

Regards,
  Dennis


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]