[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpms/viewvc/devel viewvc.spec,1.2,1.3



On Wednesday 28 March 2007, Peter Gordon wrote:
> On Wed, 2007-03-28 at 01:43 -0400, Bojan Smojver wrote:
>
> > Modified Files:
> > 	viewvc.spec
> > Log Message:
> > Drop selinux package, required context now in official policy.
>
> When you drop a subpackage, please remember to add proper
> Obsoletes/Provides to the main package so that the subpackage is
> properly removed with the next update.
>
> E.g., for your viewvc changes something like the following would
> suffice:
>
> Obsoletes:	%{name}-selinux < 1.0.3-12%{?dist}
> Provides:	%{name}-selinux = 1.0.3-12%{?dist}

I think there's no need to add the Provides in this case.  And the Obsoletes 
should be a disttagless %{name}-selinux < 1.0.3-13.

http://fedoraproject.org/wiki/Packaging/NamingGuidelines#head-3cfc1ea19d28975faad9d56f70a6ae55661d3c3d


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]