[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum: rpm_check_debug vs. depsolve: rhnlib needs python(abi) = 2.4



On 11/1/07, Jon Ciesla <limb jcomserv net> wrote:
> Agreed.  I wouldn't want to pull something off someone's system just
> because Fedora stopped carrying it, if the user finds it useful.  In the
> case of an abi dep, like rhnlib and python, yum sees that the upgrade will
> break rhnlib, so won't do it with rhnlib there, which is The Right Thing
> To Do.  Maybe we just leave all as it is, and add a list of dead packages
> to the release notes for each release, so you know what to pull beforehand
> if you want.

We need to carry around information as to what the Fedora "repository"
has stopped carrying as an optional repository metadata. Once we do
that, we can teach clientside tools to parse such repository level
data and then local admins can decide how to deal with packages which
are no longer being provided.

We could use this sort of metadata to inform users about orphaned as
well as deprecated packages on a repository by repository basis.

-jef


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]