[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: rpm core dumps



Alan;

Not to be mean, but you are kinda screwed. There is a lot of work now to
clean this up.  Glibc 2.1.5 has many dependencies. And just installing Glibc
2.2, would break about a third of the programs running on RH v6.2. You could
grab the Glibc 2.1.5 rpm from the CD, and install it with the -nodeps
and -force options. This *should* get you back to a stable environment.
(please notice should!)
Most programs have dependencies on underlying programs, libraries and such.
You should always try to Upgrade -U for Freshen -F. This will keep you out
of most trouble. If you get dependency errors. You will need to upgrade the
dependency packages.

Ie. I just installed the latest version of  rpm from the rawhide release on
my RH 6.2 workstation. I did an upgrade and it error'd stating that I need
popt v1.5.9 or better. So back to rawhide for the popt library. Upgrade
popt, upgraded rpm..
Life couldn't be sweeter..  ;-)

Kevin Ford
Chief Technologist
UniCorp IT Solutions Group


-----Original Message-----
From:	rpm-list-admin@redhat.com [mailto:rpm-list-admin@redhat.com] On Behalf
Of Alan Mizrahi
Sent:	Sunday, August 13, 2000 9:37 AM
To:	rpm-list@redhat.com
Subject:	rpm core dumps

I get a core dump from rpm almost always, example:

[root@olympus rpm-new]# rpm -e mutt-1.0.1i-6
rpm: ../iconv/skeleton.c:292: gconv: Assertion `outbufstart == ((void
*)0)' failed.
Aborted (core dumped)


This is the story:
I am using redhat 6.2.
I wanted to update to XFree 4.01 so I downloaded the RPMS from helix, I
tried to install them but I needed the new version of rpm, so I downloaded
the new version, installed it and made rpm --rebuilddb
Then I tried to install XFree but I got this error message that says I
need glibc 2.2, so I downloaded the newest version from Redhat and
installed it, but I couldn't install it as an upgrade because rpm
complained, I just did rpm -i glibc-2.1.91-16.i386.rpm without
uninstalling the old version.

Now I do rpm -qa |grep glib and I get two versions:
glibc-2.1.3-15
glibc-2.1.91-16

I cant erase the old version because I get a scaring error message and a
core dump!
I even tried with the rpm binary provided with the redhat CD, it gives me
the same error.

I can use perfectly any program I can think of (I think glibc isn't
broken).

Please help me.



_______________________________________________
Rpm-list mailing list
Rpm-list@redhat.com
https://listman.redhat.com/mailman/listinfo/rpm-list





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []