[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

perl >= 5.00503 is needed when installing Perl module on Red Hat 7



Why does this happen:

     indonesia 12# rpm -Uvh perl-XML-Parser-2.23-2.i386.rpm
     error: failed dependencies:
      perl >= 5.00503 is needed by perl-XML-Parser-2.23-2

when

     indonesia 13# rpm -q perl
     perl-5.6.0-9

and

     indonesia 14# rpm -q rpm
     rpm-4.0-4

????

Surely 5.6.0 is >= 5.00503?

Well, just as I wrote this, it struck me that perhaps it isn't, as 503
is certainly greater than 6, although I don't think the perl packagers
meant it to be interpreted this way.

So perhaps rpm is right and the versioning of the perl package is wrong,
but who's right and who's wrong is really not very interesting since

     ndonesia 20#  rpm -q perl --queryformat '%{PACKAGER}\n'
     Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
     indonesia 21# rpm -q rpm --queryformat '%{PACKAGER}\n'
     Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>

and also

     indonesia 24# rpm -qp perl-XML-Parser-2.23-2.i386.rpm
     --queryformat '%{PACKAGER}\n'
     Red Hat Software <http://developer.redhat.com/bugzilla>

Comments, anyone?

- Toralf






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []