[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RPM 4 "cpio: read" error



On Wed, 09 May 2001, you wrote:
> Hi Dima,
> I've been lurking on the RPM list for a while, and noticed your message
> indicating that you have upgraded from RPM 3 to RPM 4.  I am trying to do the
> same on a Mandrake 7.1 Linux system but am blocked by the message
> 
> "Only packages with major numbers <= 3 are supported by this version of RPM"
> 
> when I try to install the RPM 4.0.x  .rpm file.  This (catch-22) is the exact
> reason why I want to upgrade to RPM 4 - I get this on other .rpms that I am
> trying to install.
> 
> Can you advise me, or direct me to a source of info on upgrading RPM from 3 to
> 4, preferably using .rpms (vs. building from source code)?
> 
Try upgrading to rpm 3.0.5 or 3.0.6 (you may need to do a "nodeps" to get
around a bug in the specfile for 3.0.6) and then upgrading to rpm 4. However,
make sure you install ALL the errata for rpm first...
	John





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []