[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: updating rpm from 3.x to 4.x



On Mon, Apr 08, 2002 at 12:32:12PM -0400, Brandon S. Allbery KF8NH wrote:
> > How can I update from rpm 3.x to rpm 4.x if my actual version cannot
> > manage packages with major number greater than three?
> 
> Install the latest 3.x series (3.0.6?).  You may need to --force it if the
> current package still has the prerequisites bug.  It understands rpm4
> packages, so you will be able to upgrade to 4.x with it.

Simpler still is to just install rpm-4.0.4-6x packages from
	ftp://ftp.rpm.org/rpm/rpm/dist/rpm-4.0.x
Make sure you get the -6x release of
	rpm
	rpm-devel
	rpm-build
	rpm-python
	popt

You should do a "rpm --rebuilddb" immediately, install the 4.0.4 packages,
and then do a "rpm --rebuilddb" to convert from db1 -> db3 format.

FYI: An upgrade to rpm-4.0.4 on 6x is going to break rpmfind, gorpm, kpackage,
rpm2html. Rebuild from src.rpm's is the current answer.

73 de Jeff

-- 
Jeff Johnson	ARS N3NPQ
jbj@redhat.com (jbj@jbj.org)
Chapel Hill, NC





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []