[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpm-3.0.6--rpm-4.0.4 interoperability



On Mon, Sep 16, 2002 at 04:09:22PM +0200, Markus Pilzecker wrote:
> Hello,
> 
> just a simple question:
> 
>   is it possible to let rpm4 work on a rpm-3.0.6 database?
> 

There's sufficient support for db1 format databases to do a --rebuilddb
to convert to db3. Other functions will probably still work, but the
goal of this (2+ year exercise) is to phase out support for db1,
already gone in rpm-4.1.

> If possible, I would prefer not to convert the database itself [as
> suggested for upgrading], since 
> 
>   - for compatibility reasons, we want to deliver rpm3-packages

Delivering rpm3 built packages is a different problem than what database
format is used on the installed machine. Please don't confuse the problems.

>   - it's not a funny trip to compile rpm-4 on Solaris [, where our
>     rpm-3.0.6 does its job rather satisfyingly] 

Well understood.

> 
> , and rpm2html otoh seems to compile only together with rpm-4.

I've supplied patches for rpm2html for all rpm-4.0.x releases. Look
at the src.rpm's for rpm2html in various distro releases.

73 de Jeff

-- 
Jeff Johnson	ARS N3NPQ
jbj@redhat.com (jbj@jbj.org)
Chapel Hill, NC





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []