[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Dependancy generation problem.



On Tuesday, Sep 6th 2005 at 13:54 -0700, quoth Frank Cusack:

=>On September 6, 2005 4:27:59 PM -0400 "Steven W. Orr" <steveo syslang net>
=>wrote:
=>> I run the rpm -bb and I get this in the output at the end:
=>> 
=>> Processing files: guard_stap-1.0-1
=>> Requires(interp): /bin/sh /bin/sh
=>> Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
=>> rpmlib(PayloadFilesHavePrefix) <= 4.0-1
=>> Requires(post): /bin/sh
=>> Requires(preun): /bin/sh
=>> Requires: /bin/sh /usr/bin/perl libc.so.6 libc.so.6(GLIBC_2.0)
=>> libc.so.6(GLIBC_2.1)
=>> libc.so.6(GLIBC_2.2) libc.so.6(GLIBC_2.3) libc.so.6(GLIBC_2.3.3)
=>> libc.so.6(GLIBC_2.3.4)
=>> perl(File::Basename) perl(Sys::Syslog)
=>> Checking for unpackaged file(s): /usr/lib/rpm/check-files
=>> /var/tmp/guard_stap-root
=>> Wrote: /usr/src/redhat/RPMS/i386/guard_stap-1.0-1.i386.rpm
=>> Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.84050
=>> 
=>> The problem is that when I go to install it I get the following error:
=>> 
=>> bash-2.05b$ sudo rpm -Uvh
=>> /usr/src/redhat/RPMS/i386/guard_stap-1.0-1.i386.rpm
=>> error: Failed dependencies:
=>>          libc.so.6(GLIBC_2.3.4) is needed by guard_stap-1.0-1
=>> bash-2.05b$
=>> 
=>> rpm -q glibc shows that I am running glibc-2.3.2-27.9.7 and there's nothing
=>> on here (that I know
=>> of) that should be causing me to be using 2.3.4.
=>> 
=>> Can someone help? How can I shut that dependancy off at build time?
=>
=>Are you installing the rpm on the same machine you built it on?  The
=>machine you've built on may have a later version of glibc.  Doesn't
=>seem to be the case from your example, but it's the obvious problem.
=>
=>Or it may be the case that the machine you're installing on has a corrupt
=>rpm database, so it doesn't know that the installed libc meets the build
=>time dependency (the build time dependency comes from the actual installed
=>library, not anything in the rpm database).  Try
=>'rpm -q --provides glibc | grep libc' and see if there are a bunch of
=>versions there.  Then try
=>'nm /lib/libc.so.6| grep 'A GLIBC_2' and see if it agrees.
=>
=>-frank

Thanks for the help:

I am building on the same machine I'm installing on. The output of 
the two commands are below. Can I just shut off the glibc dependancy 
totally?

bash-2.05b$ rpm -q --provides glibc | grep libc
config(glibc) = 2.3.2-27.9.7
libc.so.6  
libc.so.6(GCC_3.0)  
libc.so.6(GLIBC_2.0)  
libc.so.6(GLIBC_2.1)  
libc.so.6(GLIBC_2.1.1)  
libc.so.6(GLIBC_2.1.2)  
libc.so.6(GLIBC_2.1.3)  
libc.so.6(GLIBC_2.2)  
libc.so.6(GLIBC_2.2.1)  
libc.so.6(GLIBC_2.2.2)  
libc.so.6(GLIBC_2.2.3)  
libc.so.6(GLIBC_2.2.4)  
libc.so.6(GLIBC_2.2.6)  
libc.so.6(GLIBC_2.3)  
libc.so.6(GLIBC_2.3.2)  
libc.so.6(GLIBC_2.3.3)  
libc.so.6(GLIBC_PRIVATE)  
libcrypt.so.1  
libcrypt.so.1(GLIBC_2.0)  
glibc = 2.3.2-27.9.7
bash-2.05b$ nm /lib/libc.so.6| grep 'A GLIBC_2'
00000000 A GLIBC_2.0
00000000 A GLIBC_2.1
00000000 A GLIBC_2.1.1
00000000 A GLIBC_2.1.2
00000000 A GLIBC_2.1.3
00000000 A GLIBC_2.2
00000000 A GLIBC_2.2.1
00000000 A GLIBC_2.2.2
00000000 A GLIBC_2.2.3
00000000 A GLIBC_2.2.4
00000000 A GLIBC_2.2.6
00000000 A GLIBC_2.3
00000000 A GLIBC_2.3.2
00000000 A GLIBC_2.3.3
bash-2.05b$ 

-- 
Time flies like the wind. Fruit flies like a banana. Stranger things have  .0.
happened but none stranger than this. Does your driver's license say Organ ..0
Donor?Black holes are where God divided by zero. Listen to me! We are all- 000
individuals! What if this weren't a hypothetical question?
steveo at syslang.net


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]