[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Please help: strange rpm upgrade problem:


 I'm still running 64bit FC4 on a few x86_64 platform
boxes, and trying to upgrade valgrind to 3.2.0 from
the fedora development tree. 

 the valgrind builds without problems but fails the
command "rpm -Uvh --test
with the following error messages:

error: Failed dependencies:
        valgrind = 1:2.4.0 is needed by (installed) 

I've changed the line "Obsoletes: valgrind-callgrind"
to "Obsoletes: valgrind-callgrind.i386" in
valgrind.spec file and recompiled the package but
still no luck.

 The existing valgrind and valgrind-callgrind are both
.386 packages while the new valgrind 3.2.0 version is
compiled as a x86_64 package. 

On 64bit FC4 O/S can x86_64 packages replace and
obsolete related i386 packages? if spcified with
"Obsoletes" instructions in .spec file?

Please help. Thanks a lot.

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]