[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Installed version of java should but does not match required version



Hi all:

I am trying to install a locally built RPM. using rpm 4.3.3 on centos
4.3.

When trying to install it I get:

  sudo rpm -U pipe-0.2.1-2.i386.rpm 
  error: Failed dependencies:
        j2sdk = 1.4.2_05 is needed by pipe-0.2.1-2.i386

However rpm -q --qf '%{VERSION}\n' j2sdk reports:

  1.4.2_05

this is the j2sdk as downloaded from sun so the version number is theirs.

In my spec file for pipe I have (wrapped below):

   Requires: libreadline-java >= 0.8.0, iptables-devel, j2sdk = 1.4.2_05,
             ucspi-tcp

and there is no complaint about libreadline-java, and the rpm built
successfully.

So what's going on here I'm confused.

Thanks for your help.

--
				-- rouilj

John Rouillard
System Administrator
Renesys Corporation
603-643-9300 x 111


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]