[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: [Spacewalk-list] Centos 5.2 install issue



Hi Michael,

No I'm working on a spare 32 bit machine we have, I didn't seem any *need* to be 64 bit for this system. 

But ignoring that you just gave me the solution :-)
The package perl-DateTime-Format-Mail is available via 2 repos in my yum config:
rmforge
epel

The rpmforge one is the "wrong" one for this install, so I forced it to use the EPEL one and it all works now.

Thanks a lot(and thanks to Zac for his ideas as well)
Andy


Andy Scutt 
Jobpartners - The People Relationship Management Company
VP System Operations
System Operations
Fax: 	 +44 2088340404	
Email: 	 andy scutt jobpartners com	
www.jobpartners.com	



-----Original Message-----
From: Michael Mraka [mailto:michael mraka redhat com] 
Sent: 03 October 2008 13:51
To: Andy Scutt
Cc: spacewalk-list redhat com
Subject: Re: [Spacewalk-list] Centos 5.2 install issue

Andy Scutt wrote:
% Hi Michael,
% 
% Yes EPEL ss installed and working. I actually went as far as installing the dateTime on its own:
% 
% [root lnx-mailstor ~]# yum list perl-DateTime.i386
...
% Installed Packages
% perl-DateTime.i386                       1:0.41-1.el5           installed
% 
% 
% Still get the same error for spacewalk though:
% Error: Missing Dependency: perl(DateTime) >= 0.1705 is needed by package perl-DateTime-Format-Mail
% 
% Really confused now!

Hmm, maybe the real problem is different version of
perl-DateTime-Format-Mail; mine is: 

# rpm -q  perl-DateTime-Format-Mail
perl-DateTime-Format-Mail-0.30-4.el5
# rpm -q --requires perl-DateTime-Format-Mail
...
perl(DateTime) >= 0.18

# rpm -q  perl-DateTime
perl-DateTime-0.41-1.el5
# rpm -q --provides perl-DateTime
...
perl-DateTime = 1:0.41-1.el5

Both packages taken from EPEL.
Another thing comes to my mind - don't you have 64bit system?

--
Michael Mráka
Satellite Engineering, Red Hat



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]