[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Creating RPM from the Source.

Thomas Vander Stichele wrote:


steps i followed,

1. rpm -ivh anaconda.src.rpm
2. tar xfj anaconda.tar.bz2 in the /SOURCES directory
3. cp -R anaconda-7.3 anaconda-7.3-unilogin (created one directory ... )
4. replaced "Red Hat" with "my text" inside "anaconda-7.3-unilogin" directory
5. diff -urN anaconda-7.3 anaconda-7.3-unilogin > anaconda-unilogin.patch
6. In SPECS dir , cp anaconda.spec anaconda-unilogin.spec
7. replace "redhat" with "My text" inside anaconda-unilogin.spec (In order to run step 10)
8. Added Patch:anaconda-unilogin.patch. & %patch -p1 lines in anaconda-unilogin.spec
9. rpmbuild -ba anaconda-unilogin.spec
10. rpm -qip /usr/src/redhat/RPMS/i386/anaconda-7.3.rpm --- > Result : Still no replacement made in the summary?

those steps look right to me.
What you can verify is if, during step 9, you see it actually executing
the patch command. If it's not, then you're somehow building from an old

No. I am building the new spec only. After spending a day,
finally i did the following steps:

1.uninstalled anaconda from my system.
2. Deleted all files from usr/src/redhat/Source. & /Build & /SRPMS & RPMS/i386 & SPECS
3. rpm -ivh anaconda.src.rpm (created a bz2 file in /SOURCE dir. & spec file in SPECS dir.
4. tar xjf bz2 which created anaconda-7.3 under /SOURCE dir.
5. Replaced all (remember ALL! ) occurrences of Red hat with "My text".
6. Deleted tar.bz2 file
7. tar cjfv anaconda-7.3.tar.bz2 anaconda-7.3 (Nothing but creating bz2 file from the replaced dir.)
8. Replaced all occurences of Redhat with "my text" in specfication file under /SPEC dir.
(Even i tried putting some junk characters in the summary & description like ,
*%description runtime*
*The anacondsdfasda-sdfrunsdftime psdfasdfackage csdfontains parts of the uLisdfn
ux sfdsdfinasdfstfaller which are needed for installing new systems. These file
are sdf dsfused to build dsfsdusdfLafsdinux medsdidsfa sets, but are nsdfot sdfm
eant fsdfor sdfusdfe osdfn asdflrsdfeady isdfnssdftalled sysdfssdftems.*
9. finally, rpmbuild -ba anaconda.spec (which i modified in step 8)
10. It created 2 rpms under /RPMS/i386 dir.
11. rpm -qip anaconda-7.3-runtime-i386.rpm gives

Name : anaconda-runtime Relocations: (not relocateable)
Version : 7.3 Vendor: (none)
Release : 8 Build Date: Wed 06 Nov 2002 05:21:11 PM IST
Install date: (not installed) Build Host: javclnt1.inunilogin.com
Group : Applications/System Source RPM: anaconda-7.3-8.src.rpm
Size : 3856820 License: GPL
Summary : Red Hat Linux installer portions needed only for fresh installs.
Description :
The anaconda-runtime package contains parts of the Red Hat Linux
installer which are needed for installing new systems. These files are
used to build Red Hat Linux media sets, but are not meant for use on
systems that have already been installed with Red Hat Linux.

The output shows that the description and summary was replaced with my junk (!) description given in the spec

I have searched my whole file system for the spec file , but i could not find.

Where from the summary and Description is coming ??????
Is it an Anaconda magic ??????

spec. If it is, then I see no reason why your changes to the summary wouldn't be taken into account.
Also check that the built rpm really is the one that you just built (check the date on it when you built it).

The date&time is correct.

Don't build as root either, but that's an aside.

I logged in as normal user, but could not created directories in some locations. Only root can do

And, finally, try installing it then querying it.

Not working.... Either

But generally, if these are the exact steps you did, then it should work.

It IS however easy to miss one or make a mistake in them, as I have done

in the past before ;)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]