[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Boot up problem



I followed the directions below to build a new kernel that would work with my Compaq laptop. Without this kernel nothing works on this machine (ie network, sound, modem, pcmcia etc) Everything with the build seemed to go fine but when I boot I get the following error:

mount_devfs_fs(): unable to mount devfs, err: -2
Freeing unused kernel memory: 120k freed
Warning: unable to open an initial console.
Kernel panic: No init found.  Try passing init= option to kernel

I have partitioned my hard drive with Windows XP on the first partition and RedHat on the second. I've tried passing various parameters like nomce, nopcmcia, pci=off etc, but the current options in my grub.conf file seem to work the best.Here is my grub.conf file.

title Test Linux
        root (hd0,1)
        kernel /vmlinuz-2.4.21-pre4-ac1-acpi-swsusp root=/dev/hda2 idebus=66
        initrd /initrd-2.4.21-pre4-ac1-acpi-swsusp.img


******* DIRECTIONS ******
Subject: [LinuxPresario900] Installing Redhat 8 on Presario 906us To: linuxpresario900 videl ics hawaii edu


After several weeks of messing around with different release (I tried Debian
Woody and Redhat 8), I finally
manged to get Linux to install on my Presario 906us. Presario 906us is a
little different than the 900 machines. It doesn't have Irda and it does not
have a IDE floppy drive. I eventually settle on Redhat because I had great
difficulty with Debian X setup. Neither KDE or Gnome would start up properly
in Debian.
My Presario 906us is also setup a bit differently than the out-of-the-box
machine. I erased the Windows XP from the hard disk and installed:
hda1 - Windows 2000 server.
hda2 - Linux Ext3
hda3 - Swap
The whole thing boots into grub, which allow me to select either NT or
Linux. I guess lilo would work, though grub is a bit easier to work with (I
keep forgetting to type lilo before reboot).
Here's what I did:
1. Boot Redhat 8 CD 1
2. At the command line prompt, type linux pci=off.
For some reason, if you don't turn off the pci bus detection, the CD-ROM
will never be detected. You'll notice this problem right away because Redhat
can't continue installation because it can't find the CD and you can't eject
the CD. I have tried pci=biosirq and other settings, but pci=off seems to be
the only one that works.
3. During install, I followed most of the defaults, except:
- Select Generic 3 button mouse and check the "emulate 3 button".
- Select Workstation
- I manually partition using disk druid mainly because I had set up the
partitions previously.
- On firewall, I just set up medium and default.
- When prompted for workstation defaults, I select customize the package and
then checked "Kernel Development". We'll need this package to install the
new kernel later.
- Select the VESA driver, since no other driver will work.
- Select the Generic laptop display panel 1024 x 768.
- When prompted to create a boot floppy, say no. You can get Presario 906us
to boot from the USB floppy if you turn on usb legacy support in the BIOS,
but this will crash your keyboard during install.
4. After install, reboot machine.
5. On the grub prompt, select the Linux boot and press e. Edit the vmlinuz
line and add "nomce pci=off". If you don't add the nomce, the machine will
boot into a kernel panic.
6. At this point redhat install will continue with date and time settings
and the rest of installation.
7. After the installation, edit /boot/grub/grub.conf and add the boot
parameters "nomce and pci=off".
At this point, you have a system that sort of works. Everything is working
except for USB, modem, sound, and PCMCIA. To get those component work,
you'll need to compile a new kernel.
8. Download kernel-source-2.4.21-pre4-ac1-acpi-swsusp.tar.gz from the
http://metaverse.wuh.wustl.edu/~cypher/presario900/2.4.21-pre4-ac1-acpi-swsu
sp/ and copy it to /usr/src.
This is where it gets tricky. The problem is that the modem and network is
not working, so you can't really download the software directly into Linux.
There are several ways around it.
a) If you have dual boot, you can download your file into NTFS partition,
then mount them from Linux and then use cp.
b) Burn the software to a CD from Windows and mount the CD from Linux.
c) start the machine with the kernel boot option "nomce" instead of "nomce
pci=off". This will disable your CD-ROM,. but you'll be able to get access
to USB. I then download the software to a vfat USB drive, mount the drive
from Linux and copy the software to it. This is the route I took.
d) If you start the machine with just nomce, you can probaby config PPP to
work and download the file in Linux. Your CD-ROM will however be disabled.
Next, we'll unzip the source file and compile a new kernel.
9. Login as root
10. Open a terminal.
11. cd /usr/src
12. tar -xvzf kernel-source-2.4.21-pre4-ac1-acpi-swsup.tar.gz
13. rm -f linux-2.4
14. ln -s kernel-source-2.4.21-pre4-ac1-acpi-swsusp linux-2.4
15. cd linux-2.4
16. make oldconfig This will set up a new config file.
17. make xconfig This will launch the kernel config screen. You'll need
to:
- In Block device, set normal floppy support to No. Presario 906us does not
have a normal floppy.
- In File system, set JDB Debug to Y, otherwise you'll get a jdb error at
start up.
- In File System, set NTFS Write support to No, because it seems dangerous.
- In File System, set /dev to No, otherwise you'll get a kernel panic at
startup unless you have devfsd installed. Note that you devfsd is
experimental.
- In USB support, set USB Mass Storage to Y.
- Select Save and Exit
18. make dep
19. make clean
20. make bzImage WARNING: I notice that this sometimes end with a error
2. In those situations, I run make dep, make clean and make bzImage again
and the problem usually goes away.
21. make modules
22. make modules_install
23. make install
24. depmod -ae 2.4.21-pre4-ac1-acpi-swsusp
25. edit /boot/grub/grub.conf. Change the root entry from root=/LABEL=/ to
root=/dev/hda2. Change boot paramter from "nomce pci=off" to "idebus=66"
NOTE: Without the idebus=66, the machine does not start properly.
26. Shutdown machine.
27. Power off machine and restart.
At this point, the machine should work. Network card, modem, pcmcia, and usb
should reappear. Sound should work fine at this point.
There are still some issues.
- X only works with the VESA display driver. If you want drivers for the
chipset, you'll need to download a later version of Xfree86.
- In the dmesg log, there are a lot of entries that said "out of mtrr". I am
not sure what mtrr is.

Any ideas or suggestions?

Thanks

Robert Haack
Programmer/Analyst
Phone: (503)353-6100
Fax: (503)353-6115
haack nclack k12 or us

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]