[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Anaconda and tty2



On Wed, 2006-01-25 at 10:38 -0500, Matt Wilson wrote:
> On Wed, Jan 25, 2006 at 05:26:08PM +0530, Ajith Vargese Thampi wrote:
> > Hi,
> > 
> > When i build my custom anaconda-10.2.0.5. I dont get the tty2 while i
> > get the tty3/4 and others.
> >
> > What could be the issue with tty2 not loading? Has it anything to do
> > with busybox.anaconda being problematic? or is it anything to do with
> > bash being problematic?
> 
> tty2 only comes up after you load stage2, since that's where bash is.
> At what stage are you missing tty2?

Yes, tty2 problem is at stage2. I have considered trying with bash, a
static bash and ash shells but to no avail. Is there any need for a udev
filesystem over devfs filesystem for /dev ? i am presuming as No, but
does it?
I am currently looking into the init code. So i should try to put in
more details.

> 
> > Also, i get really untidy text. Could this be because of the locales?
> > how do i make sure the locales are present properly?
> 
> Yes, that's normally a locale problem.  Make sure the locale data
> storage method matches the way that upd-instroot is copying locale
> data.  Newer versions of glibc like to create a locale archive instead
> of many individual locale files.

I see that there is something called a build-locale-archive trying to be
used from anaconda. My distro does not have such a locale archive.

What exactly is anaconda trying to get from locales? where does it look
for for and what comprises of a correct locale/locale archive in terms
of anaconda? maybe i can hack out little details of it?

> 
> > Also, i have xorg running successfully and then the next instant it
> > crashes with an IO error 104 in mini-wm. Are gnome packages ever
> > necessary for anaconda to run in graphics mode? 
> 
> This sometimes happens when anaconda's gui mode exits abruptly.  That
> takes down X and kills miniwm's X connection.  You do need some GNOME
> libraries (libgnomecanvas for example).

But why does anaconda's gui mode exit abruptly? Any package
dependencies? How can i debug this problem?

Only if i could get tty2 to work, which would make things much simpler.

> 
> > Please do hoping for some  tips from the masters.
Still hoping for more ;)

Cheers
--
Aristo


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]