[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rhn-users] Kickstart Issue - Custom Bootdisk to Network Install








Warren_Crigger navyfederal org wrote:
>>> I do not have the luxury of using DHCP and the normal method of
>>> kickstart, so I made a custom boot CD with the isolinux directory and
>>> TRANS.TBL file on it from the actual RHEL4AS disk (that's it!).  I can
>>> boot normally and from there give it testing kickstart boot options
>>> which are:
>>>
>>> linux ks=http://<ip>/profiles/ks.cfg ip=<ip> netmask=<netmask>
>>> gateway=<gateway> ksdevice=eth0
>>>
>>> It then loads the kernel, starts to grab files off the remote server
>>> (see logs below), fires up anaconda, detects the video/mouse/etc, and
>>> then says:
>>>
>>> "you are trying to install on a machine which isn't supported by this
>>> release of Red Hat Enterprise Linux ES"
>>>


>> From a quick search I did... I could only find information relating to
>>it being a missing kernel in your repository(there were a few others
>>relating to a missing architecture which the Dell PE1650 should be i686).

>>https://www.redhat.com/archives/fedora-list/2004-May/msg08527.html

>>The link points to older distro's but the reason for the error shouldn't
>>be that different...  If this is the first box you've tried off the
>>repository, might be worth another look to make sure it has all the
>>files off all the cd's and permissions are correct for the webserver.

>>Hope that helps,
>>-Mitch


>Thanks for the response + info.  I'll check for the 'missing kernel' - I have several kernels in the repository, but none just simply named "kernel.rpm (until now, I copied what kernel I normally use over to that name as well)."  >I'll test this out tomorrow as I'm headed home for the day...


>You'll notice in the apache logs from the box serving up the media that there are 2 404's for a .img file.  It never complains about that during the install - Only later after anaconda does its thing and it loads a few more >files(product, netstg2 images + hdlist and comps.xml).  I copied the media per the documentation, until I found that RH was looking for more than what was documented, then copied everything.  I can verify ownership is correct, I >did a recursive chown on em all earlier after loading up more stuff off the CDs and actually the permissions are wide open temporarily so my samba user can access them while testing (yea, yea, I know =P).


>Thanks!

I tried this this morning with no luck.  The kernel.rpm being there makes no difference, it still states "you are trying to install on a machine which isn't supported by this release of Red Hat Enterprise Linux ES."  The only clue I have is that its looking for "updates.img" from the install source after looking at the apache error logs.  I'm at a loss :(  I can't find that file on the disks or in my repository, and googling it isn't helping a whole lot, apparently I have to create it but I'm unsure of how to.
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]