[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Updating an older Fedora Core 5 installer to feature newer kernel modules

On Mon, 2007-06-04 at 15:52 +0100, Matthew Bloch wrote:
> What I've tried so far is to extract the stock pxeboot/initrd.img and
> the contained modules/modules.cgz files.  Then I add in the .ko files
> from the RPMs that nVidia supply for FC5, then rebuild it all with cpio
> / gzip.   Unfortunately anaconda still says it doesn't have a driver
> "for the specified installation type", even though I'm 99% sure that the
> forcedeth.ko file bring up an eth0 (not sure how to launch a shell from
> the loader to check ;) ).  I even tried copying the FC5 x86_64/os
> directory onto a local drive, then re-launched the network installation
> and asked it to install off a local hard drive.  Again the "no driver
> found for specified installation type" complaint, even though it offered
> to load a driver disk off the filesystem on /dev/sda1 which it could
> clearly access ;-)

If you're doing a network install, though, then it's not finding the
network card.  And what you're _probably_ running into is the fact that
some (incredibly broken) nForce BIOSen don't actually expose the network
device with one of the PCI networking device classes and instead is
exposed just as a generic bridge.  Eventually, we hacked kudzu to ignore
this silliness, but I'm not 100% sure if that was in FC5 or not.  If
not, you could probably grab the patch to kudzu and just apply it to the
older kudzu and rebuild the loader.

Generally what you're doing looks like it should be fine; I think you're
just getting hit by a particularly non-friendly driver.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]