[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

buildinstall/mk-images and isolinux.cfg problems



I tried the CentOS list for this but nobody seems to know. Since this may
be related to mk-images which is part of Anaconda I thought I would try
here...

When using buildinstall and CentOS 5.2 to create my own CD minus a bunch
of unneeded RPM's and plus a few of my custom RPM's I find that the
install CD that gets build does not install an initrd which renders the
system unbootable.  I also notice that when I run buildinstall with the
-debug option it says:

unpacking
/var/www/html/centos/5.2/os/x86_64/CentOS/kernel-2.6.18-92.el5.x86_64.rpm.x86_64
Building initrd.img
Module 3c501 not found in kernel rpm
Module 3c503 not found in kernel rpm
Module 3c505 not found in kernel rpm

and so on for many kernel modules. I notice that the filename it says it
is unpacking ends with .x86_64.rpm.x86_64. Is that normal? I google'd and
found someone else saying theirs did the same thing. Could this be related
to why I'm not ending up with an initrd being installed?

And while I'm here let me run another one by you that the CentOS list
couldn't answer...

I have added a few custom RPM's to my CentOS 5.2 CD, dropped a
kickstart.cfg file in the root of the CD, and now want to change the
isolinux.cfg in the boot.iso so that it will automatically do a kickstart
install when the CD boots up.

I am using buildinstall to make the ISO. I edited the isolinux.cfg in
/isolinux in my CentOS 5.2 distribution tree off of which I am building my
ISO.

But after buildinstall runs the isolinux.cfg is changed back!

Where is it getting the original from? Where should I be changing it to
get my modified isolinux.cfg into my cd?

Just to get around the isolinux.cfg issue manually I tried booting and at
the prompt I say:

linux ks=cdrom:/kickstart.cfg

But it says that it cannot find the kickstart.cfg file. Is it expecting it
in the root of the boot.iso or of the CD? I put it in the root of the CD.
I can mount the CD and see that it is there. I can't figure out how to put
it in the root of the boot.iso (if it even needs to go there) because
apparently that is getting remade by the buildinstall also and I'm not
sure where it is getting the contents from.

Here is the entire process I use for building and burning the ISO:

/usr/lib/anaconda-runtime/buildinstall --version 5 --product CentOS --comps
/var/www/html/centos/5.2/os/x86_64/repodata/comps.xml --release MyCentOS-5
--prodpath CentOS /var/www/html/centos/5.2/os/x86_64

mkisofs -R -J -T -r  -l -d -allow-multidot -allow-leading-dots -no-bak
-o /var/www/html/centos/5.2/isos/MyCentOS-5.2-x86_64.iso
-b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot
-boot-load-size 4 -boot-info-table /var/www/html/centos/5.2/os/x86_64/

cdrecord blank -fast -dev=/dev/sg1 -v -eject /var/www/html/centos/5.2/isos/MyCentOS-5.2-x86_64.iso

Any help would be greatly appreciated!

-- 
Tracy Reed
http://tracyreed.org

Attachment: pgp1VQD2FSn5Z.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]