[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Anaconda sets up grub right, grub-install does not...



I have multiple production machines that I support.  They are running Centos 5 with /boot and / on software RAID1 across 3 drives.

 

When anaconda sets up the boot loader the machines work fine.  Great.

 

We recently had /dev/sda fail on one of the machines.  We replaced the drive, rebuilt the partitions and tried to re-install grub using

 

Root (hd0,0)

Setup (hd0)

Root (hd1,0)

Setup (hd1)

Root (hd2,0)

Setup (hd2)

 

Grub says it installs perfectly.  However , when I reboot, after we go though the grub menu the boot hangs after displaying the initrd information.

 

If I boot off of a DVD that can then boot the harddisk, the DVD boots, boots the grub menu from the disk, and then boots the HD correctly.

 

I have not been able to manually set the bootloader to work.  We tried doing a centos upgrade to the same version of centos that we are already running.  I set it to update the bootloader.  It runs though the process and afterwards the bootloader works correctly again.

 

What does anaconda do to install the bootloader?

Do you use grub directly or write your own?  

Have you seen this before?

 

Thank you.

 

--

Andrew Lundgren

 

 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]