[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [PATCH take 3] Don't hardcode the device for luksOpen. (#500830)



> Hardcoded device names are really bad, and we shouldn't be using them.
> 
> We don't interpret variables in strings, and it's very invasive to add
> that functionality, so instead, build the entire cryptsetup command line
> ahead of time, and pass it as an environment variable to plymouth.
> 
> This adds two commands, setDeviceEnv and buildEnv.  setDeviceEnv stashes
> a device ("/dev/sda2" or "UUID=blah" or "LABEL=blah") into an
> environmental variable.  buildEnv builds an environmental variable from
> its command line.

Based on where we are in the release process, this looks like a
reasonable way to achieve variable substitution.

- Chris


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]