[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [PATCH rhel5-branch] Install the right arch of anaconda's required packages (#541323).



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 07/16/2010 08:07 AM, Chris Lumens wrote:
> Without this, we could end up pull in a pretty big list of i?86 packages on
> an otherwise x86_64-only system.
> ---
>  yuminstall.py |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/yuminstall.py b/yuminstall.py
> index 14c3334..b6b08f6 100644
> --- a/yuminstall.py
> +++ b/yuminstall.py
> @@ -1205,7 +1205,7 @@ class YumBackend(AnacondaBackend):
>      def selectAnacondaNeeds(self):
>          for pkg in ['authconfig', 'chkconfig', 'mkinitrd', 'rhpl',
>                      'system-config-securitylevel-tui']:
> -            self.selectPackage(pkg)
> +            self.selectPackage("%s.%s" % (pkg, rpmUtils.arch.canonArch))
>  
>      def doPostSelection(self, anaconda):
>          # Only solve dependencies on the way through the installer, not the way back.

Ack

- -- 
Brian C. Lane <bcl redhat com>
Red Hat / Port Orchard, WA
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iQEVAwUBTEDcmxF+jBaO/jp/AQI8xQf+KosaBwvQ90e+P5oon2mbe27LspM8wWk5
npUMD+7ZIthvetIeRL5xmWMshyG9do+FCGVWB2gatAXh583XXrqZx4cOtBb9gWbM
O535ERwBWCFRo3vNQ7YdlqEqN35q+GvX+pJejWfuRdeUM3LzY9Pbw/ROSNMnNZdy
3EOntLCv6p9UO5pEn4qd6CTF2K65D85IwbqZV/G18bDgjvUZ3WBs8ttkK4I0z7/s
xvRxkQLm5EGFgQohQ4nLWNpWYq3Fv1h1uBwQzND/ZdV6dN5jIdq4O6rh8ts5ARfW
QcWFm6JgkIo+M4fN7TJNbRQjCzTai3MxWGzmoGq5o/rqf9hqUdOLdA==
=iAEu
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]