[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Installing CentOS 7 with livemedia-creator



Here's an update. The short version is that Brian's response
answers all my initial questions. Many thanks!

On Monday, January 5, 2015 12:23 PM, Brian C. Lane wrote:
> On Wed, Dec 17, 2014 at 06:26:36PM -0500, Christopher Cawlfield wrote:
>
> > Well, this is a little embarrassing. I've answered some of my
> > previous questions already. Two issues were misleading me:
> >
> > One, when using --no-virt, I need to be careful to remove any
> > files left over in /tmp/ and /var/tmp/. I seem to pick up stale
> > repo information when I don't do this and livemedia-creator
> > fails. This doesn't seem completely rational, but cleaning up
> > helps give me reproduceable results. I'm doing:
> > sudo rm -rf /tmp/yum.cache /tmp/yum.repos.d /tmp/yum.root /tmp/anaconda-yum.conf
> > sudo rm -rf /var/tmp/yum.*
>
> This is fixed in lorax-19.6.30-1, for centos you should be using the
> rhel7-branch instead of master.

I had tried using the master branch, ran into different
problems, and then went back to the Centos 7 lorax package, which
probably corresponds to the lorax-19.6.28-1 tag. I'll try the
rhel7-branch going forward.

> > Another issue was that I was using an HTTP server for my mirror
> > that yum did not like: Python's SimpleHTTPServer. After
> > switching to Nginx, this started working again. I don't know
> > why this is necessary, but I'll grab more wireshark captures
> > tomorrow to compare. I have a feeling that the issue *might* be
> > HTTP 1.1 vs 1.0, or maybe MIME types? Anyway I'll work that out
> > soon.
>
> yum uses partial file requests so you need a full-featured server like
> lighttpd or nginx.

Okay, this makes sense. I struggled a bit to isolate the problem
with various Python SimpleHTTPRequestHandler options and analyzing
packet captures, but wasn't getting anywhere.

> > Next I will revisit my "updates" repo, which I see now needs to
> > be named almost anything except updates.
>
> You shouldn't name a repo updates unless you just want to enable the
> default updates repo (which will be wrong for your use case), it
> conflicts with the internal name, use something like updates-foo
>
> https://fedoraproject.org/wiki/Anaconda/Kickstart#repo

I found that for installing updates from a CentOS updates
mirror, the name did not ultimately matter. I was confused by the
fact that, according to the Kickstart documentation (your link
above), I can use the name "updates" specifically to re-enable
the updates repo that is disabled by default. But
README.livemedia-creator says:
   "You can also add an update repo, but don't name it updates."
The following worked for me in my kickstart file, but
"--name=myupdates" appeared to work just as well as "--name=updates":

repo --name=myupdates --baseurl="http://localhost/7/updates/x86_64/";

This gave me an installation with updated packages. Hooray!
In this case I was using --no-virt, and localhost was hosting a
local CentOS mirror. This gets a little more complicated using a
virt install, and I haven't yet worked out the host IP for libvirt
guests. Instead I just set up another mirror on my LAN.

I was also able to create my own RPM, a custom kernel, following
instructions at http://wiki.centos.org/HowTos/Custom_Kernel. I
needed to use createrepo in order to get the repodata
subdirectory for my packages, but that's not too surprising. This
became another "repo" in my kickstart file, and I specified the
custom kernel version in my %packages section. I have yet to
determine whether or not I can use the CentOS kernel and simply
provide extra modules. That goes beyond the scope of this
discussion.

> > I'm still very curious if anyone has examples of using the
> > --make-disk option.
>
> --make-disk is actually the default code path, that's why you don't see
> any opts.make_disk references. It should work just like --make-iso
>
> The kickstart restriction is that /boot and / need to be the same
> partition so that it can find the kernel and initrd after the
> installation is complete.

Ahh, okay. Yes, once I finally just tried this option it worked
perfectly! I just copied the resulting image to a (CompactFlash)
disk with dd and it booted.

I haven't gotten to the point of worrying about a separate boot
partition yet. I will probably want this in the future, so I'll
have to keep this restriction in mind. Maybe I can work around
this with symlinks or an overlay when the time comes.

Thanks again,
   Topher



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]