[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Promise, raid 1 fail, reconstruction problems.



Today i have been playing around with the raid array some more and have came to a couple conclusions. When I run e2fsck on each indavidual drive, it works flawlessly, but it i run it on the raid array i get "Unable to handle kernel NULL pointer dereference at virtual address 00000000 printing eip:
blah blah blah.. Can include if you think it may help...


Code: Bad EIP Value.
    Segmentation fault.

As you can see, i have finally been able to boot the machine, by simply taking the array out of fstab. But as i was working with the machine, i cam arrost the original kernel which was used with the default install of debian woody. I booted with that, and all of my problems magically disapeared. Which creates a larger question. The only difference that i can see between the 2 kernels is that the one that works is 2.4.18, and the one theat doesnt is 2.4.19, and that 2.4.18 uses modules and i did not. But, i have tried compiling 2.4.18 with the original config file, but i run into the sam problem. How can this be? Is it truley a kernel problem? I can't use the oridignal kernel for my network card is not supported.

Thanks for all of your time,

Paul



Paul wrote:

Hello,
I have a raid 1 array, that has a fialed disk. I have repleaced the disk, and duplicated it with the promise fasttrack program. But when i boot my system, kernel 2.4.19 complains:


During boot, when the kernel is listing the arrays, it states that only one disk is in the array, when in fact there are two. Then it says code: Bad EIP value, and the warning fsck.ext3 for device /dev/ataraid/d1p1 exited with signal 11. It then tells me to repair manually. Cuuld this possibly be a bad superblock? I am quite confused, and have tried several things. I have compiled different versions of the kernel, from 2.4.18 to 2.4.21 but i have the same problem with all of them. I have even tried to compile them on another machine, still no luck. Has anyone succesfully done this?

Thanks,

Paul


_______________________________________________ Ataraid-list mailing list Ataraid-list redhat com https://www.redhat.com/mailman/listinfo/ataraid-list










[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]