[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[augeas-devel] [Augeas] #295: Provides backward compatibility for lenses



#295: Provides backward compatibility for lenses
------------------------+---------------------
 Reporter:  fgiraldeau  |       Owner:  lutter
     Type:  defect      |      Status:  new
 Priority:  major       |   Milestone:  next
Component:  Augeas      |     Version:  0.8.0
 Keywords:              |  Blocked By:
 Blocking:              |
------------------------+---------------------
 When changing the tree generated by a lens, it may introduce backward
 compatibility issue for all scripts in the wild that are using this lens.

 To solve this problem, we may arrange lenses in directories according to
 versions. Hence, the user can fix the lens version he is using and better
 control the update process.

 This is not always the case, for example the square lens is not compatible
 with the previous version. But as the language is now pretty stable, I
 think we can support, say, lenses changes for the whole 1.0 series.

 For example, let's say we have augeas 1.6, but it introduce backward
 incompatibility, then the user could do:

   augtool --compat 1.5

 and it would load lenses as shipped with augeas 1.5. The easy way to do it
 is to ship in a different directory all the lenses at that time. If it
 becomes too big it some point, then we could use a mechanism of overriding
 of lenses and put only lenses that changed. Or is the previous version
 enough? Like "augtool --legacy" would load lenses from the previous
 release, and only two sets would be shipped at any time?

-- 
Ticket URL: <https://fedorahosted.org/augeas/ticket/295>
Augeas <http://augeas.net/>
a configuration API


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]