[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [augeas-devel] augtool is choking on xml - help!



On Fri, Feb 17, 2012, at 01:02 PM, Dominic Cleal wrote:
> On 17/02/12 12:59, Biltong wrote:
> > On Fri, Feb 17, 2012, at 11:35 AM, Dominic Cleal wrote:
> >> On 17/02/12 11:24, Biltong wrote:
> >>> I can't see what I am doing wrong. Can anyone help?
> >>>
> >>> $ cat /tmp/web.xml
> >>> <?xml version="1.0" encoding="ISO-8859-1"?>
> >> [snip]
> >>> augtool> print /augeas/files/tmp/web.xml/error
> >>> /augeas/files/tmp/web.xml/error = "parse_failed"
> >>> /augeas/files/tmp/web.xml/error/pos = "43"
> >>> /augeas/files/tmp/web.xml/error/line = "1"
> >>> /augeas/files/tmp/web.xml/error/char = "43"
> >>
> >> Does the file have Windows/DOS style line endings?  Try dos2unix?
> > 
> > Aha! That was it - thanks! So I guess this is a bug on my side, since
> > XML files should use unix line endings?
> 
> There's no requirement in XML that they do as far as I know, so it's
> just the Augeas lens that isn't permitting it.
> 
> > Okay to file an RFE for a nicer error?
> 
> Even better, please file an RFE to get them supported.

Done: https://fedorahosted.org/augeas/ticket/257

> 
> https://fedorahosted.org/augeas/  (you need a Fedora/FAS account)
> 
> I think the subject of Unix vs. Windows line endings has come up before,
> but since Augeas is primarily used for Unix file types then I don't
> think any lenses support Windows line endings.  XML seems like a good
> exception to the rule IMO.
> 
> -- 
> Dominic Cleal
> Red Hat Consulting
> m: +44 (0)7817 878113
> 

-- 
http://www.fastmail.fm - Faster than the air-speed velocity of an
                          unladen european swallow



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]