[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [augeas-devel] building on OSX (Lion)



On Wed, 2012-07-18 at 16:06 -0400, David Blank-Edelman wrote:
> Hi-
>   Before I dig more deeply into this, I'm curious if anyone has any advice for building augeas under OSX? The two packaging systems I use (MacPorts and Homebrew) both have 0.10.0 available, but both build a non-working package that throw errors like this:
> 
> dyld: lazy symbol binding failed: Symbol not found: _strchrnul
>   Referenced from: /usr/local/Cellar/augeas/0.10.0/lib/libaugeas.0.dylib
>   Expected in: flat namespace
> 
> Looking back at the mail archive, it seems that the use of strchrnul()
> even though some operating systems didn't provide it  (and at the
> time, neither did the version of glib shipped with augeas) was
> discussed in relationship to Solaris, but I didn't see anything on the
> mailing list saying this had been worked around in the main
> development tree. 

I am not sure what causes this particular issue - augeas explicitly
requests the strchrnul module from gnulib; so this might be a gnulib
bug. Have you looked through your config.log to see if there's anything
interesting about it ?

> I also saw David mention in June the possibility of cutting a new
> release (perhaps with that fix) back in June, but I don't know if that
> addresses the strchrnul() problem.

I have to admit I am not sure which discussion you are referring to for
the fix - the only recent Solaris discussion I recall was around making
augeas buildable with the Sun compiler ... as for a release, I am sorry
it's still not there. First, vacation, and then other stuff intruded.
But I still want to make one soon(ish)

> For fun, I thought I would try to build off HEAD on github using the
> instructions in the HACKING docs. autogen.sh works fine and produces a
> working configure and glib submodule. But when I actually try to build
> augeas, it gets this far:
> 
> Making all in src
> echo '#define DATADIR "/usr/local/share"' > datadir.h1
> ../build/aux/move-if-change datadir.h1 datadir.h
> make  all-am
>  CC       fa.lo
>  CC       hash.lo
>  CC       memory.lo
>  CC       ref.lo
>  CCLD     libfa.la
>  CC       augeas.lo
>  CC       augrun.lo
>  CC       pathx.lo
>  CC       internal.lo
>  CC       syntax.lo
>  YACC     parser.c
> /tmp/augeas/augeas/src/parser.y:46.1-5: invalid directive: `%code'
> /tmp/augeas/augeas/src/parser.y:46.7-14: syntax error, unexpected identifier

This might be an issue with bison being too old - I have bison-2.5 on my
Fedora system.

Let me know if any of this helps resolves this problem,
David




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]