[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Docs for programming FDC on Alpha



B. James Phillippe writes:
 > Ah, are you running 2.0?  The problem I am having must be 2.1 related,
 > then.  

Yep, the 2.0.35 alpha kernel. I have 2.1.130 running but have never
actually tried to use the ftape driver (lucky me).

 > The first problem I had (I am using 4.02, btw [trying to use it,
 > anyway]) was with the inclusion of <asm/current.h> by <linux/sched.h>.
 > David Miller pointed out that I needed to add "-mno-fp-regs -ffixed-8" to
 > the MCONFIG.  That got me almost all the way.  The compile bombed out later
 > on 2.1-related timeout handling changes.  Perhaps it was unwise of me to
 > "lay into" the ftape sources as much as I did.  I think I overreacted to
 > the apparent unconcern by the ftape people for Alpha support, even after
 > offering to provide access to an Alpha for development.  If you have it
 > working on 2.0 though, I suppose there is much hope for 2.1.
 
I should hope/think so. I had actually given up on ftape (I have tried
almost all previous versions ;-() until I tried the 4.xx versions.

Cheers -- Jaap



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []