[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Weirdness with AlphaPC 164: installing SRM firmware, etc.



I am trying to update an lx164 to SRM to run Tru64.  It locks up at
'jumping to secondary boot strap' after validating the boot block on
the cdrom.  I'm suspecting the Diamond GL Pro video card as not being
a good match to the Elsa Gloria, even though its a Permedia2 based
card.   What kind of video card to do you have?

On Thu, 9 Dec 1999 20:46:53 -0700 (MST), you wrote:

>
>I recently purchased an old AlphaPC 164 motherboard and processor, and am
>having a hard time getting it running.  Specifically, I am trying to
>replace the AlphaBIOS with SRM and just can't get it to work.  I'm also
>having some funkiness with the built-in IDE and floppy controllers.
>
>I know all of this has been answered on this list before, but after
>digging through the archive for an hour I haven't found solid answers to
>all of my questions.  So.... please excuse the repetition. 
>
>
>1.  I have Tru64 UNIX here, which includes the SRM Firmware Updates CD.  I
>copied off the AlphaPC164 directory to a FAT-formatted floppy and tried
>"Update Firmware" in AlphaBIOS.  I get blinky lights for 3 seconds, then a
>"device error" without further info. 
>
>2.  Interestingly, AlphaBIOS seems to be recognizing the floppy only if it
>is plugged into the first port on the cable; that is, the one before the
>twist.  If it is plugged into the end (after the twist) it will recognize
>it, but only as a secondary floppy.  Isn't this backwards? 
>
>3.  I have tried running fwupdate.exe directly ("Run a program: " with
>either "a:\fwupdate.exe" or "multi(0)disk(0)fdisk(0)\fwupdate.exe") and
>get the same behavior as in 1.) above.  Yes, I have tried different floppy
>drives and cables.  Yes, I have them plugged into the motherboard with the
>red wire on the 1 pin. 
>
>4.  A Fail Safe Boot firmware update accesses the floppy drive for about
>50 seconds, with the screen blank, but nothing is different when I reboot
>after that. 
>
>5.  With the Firmware CD in an ATAPI CD-ROM drive on the secondary IDE
>bus, I get the same behavior as with the floppy.  Tried blind, dumb
>"upgrade firmware" as well as permutations on "run a program".  Don't have
>a spare ATAPI CD-ROM to try to make sure it's not hatred for this specific
>drive.
>
>6.  With the Firmware CD in a SCSI CD-ROM drive attatched to an Adaptec
>2940UW SCSI controller, I get nothing ("device error" again I believe) 
>when I try an "update firmware" from the main screen.  If I try to run it
>directly (run program scsi(0)cdrom(4)fdisk(0)\alphapc164\fwupdate.exe) I
>get an "Invalid image" error.  Which I take to mean that the executable is
>not valid for some reason...? 
>
>7.  Installing Windows NT from CD-ROM (with the SCSI CD-ROM) works great. 
>It dies when it can't find the floppy drive for the drivers floppy (only
>have a two connector floppy cable right now, so NT would have to look to
>drive B: I guess, which it won't do), but other than that it works fine.
>
>
>I'm going to continue trying different permutations (ATAPI CD-ROM on the
>primary bus) and work arounds (disguise fwupdate.exe as the NT installer
>program; put fwupdate.exe on a hard drive; etc.), but I wanted to make
>sure I wasn't doing something obviously wrong.  Could the power supply
>(only 275W, from PC Power & Cooling) be too weak, thus causing some subtle
>brown out, such that everything works fine except the firmware update?
>
>Likewise, I have the green ATX soft-power wire grounded to the side of the
>power supply (both ends of the wire: PS and motherboard ends).  Should I
>instead ground it to the neighboring black ground wire?  Is this perhaps
>subtlely screwing things up?
>
>Maybe a dying CMOS(?) battery?
>
>Finally, I saw in the May archives that someone had a work around for
>updating the firmware when it just wouldn't work the way it should... but
>I couldn't find the details of the actual work around.  Does anyone
>remember what it was, or if it would apply to this situation? 
>
>
>Thanks in advance for any help,
>
>	-Joel



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []