[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Unexplainable fatal SCSI behavior



About two weeks ago I tried to install DEC UNIX 4.0D on my 164LX which
has a ncr53c895 which I thought was supported but turned out it wasn't.
During this time I was swapping in hard drives and trying to load DU not
realizing my SCSI card wasn't supported. Now that I've switched back to
AlphaBIOS and milo some strange things are happening to my scsi card.

This is my problem. My card has a total of 4 jacks on it. the External
68 pin U2W bus, the Internel U2W bus which is part of the external bus,
an internal 68 pin UW bus, and a internal 50 pin SCSI-2 bus. The drive
in question that is cauing me this headache is a fujitsu 4.3 gig UW HD
which I've owned for about 2 years now. The controller card is a
DigtialScape DataStorm 32 Plus.

My SCSI subsystem consists of the following devices:
9.3GB Quantum Atlas III U2W LVD HD
4.3GB Fujitsu UW HD
32X  Toshiba CD-ROM
4X/12X Plextror CD-R

The Quantum is on it's on chain with an active terminator.
The Fujitsu is on it's own chain with termination set on the drive
The Toshiba and Plextor both site on the same SCSI-2 chain with
termination set on the Plextor. 

This configuration worked flawlesses untill I started to fool around
with DEC UNIX and changing my firmware to SRM. Now having flashed my
bios back to AlphaBIOS with the exact same configuration I recieve this
error just after the kernel logger starts I hit an endless loop.

ncr53c895-0: command processing resumed
scsi0 channel 0 : resetting for second half of retries.
SCSI bus is being reset for host 0 channel 0

ncr53c8xx_reset: pid= 3649 reset_flags=1 serial_number=0
serial_number_at_timeout=0

ncr53c895-0: resetting, command processing for two seconds
scsi0: device driver called scsi_done for a syncronous reset.
ncr53c895-0: enabling clock multplier
ncr53c895-0: Dwonloading SCSI SCRIPTS.

Now if I turn the machine off and connect my Fujitsu to the U2W chain
along with the Quantum it works fine but now both drives run at 40
MB/sec
so I lose out on half the bandwidth the Quantum can offer. Now check
this out. I can take both drives and put it on the UW chain and it boots
fine but again it's 40MB/sec. Now I'm totaly confused. I'm running stock
RH 6.0 kernel. I've already fdisked and LLF the Fujustu to no avail.
I've come up with two possibilites neither of which are very good for
me. Either the UW chain was somehow damaged by all the drive swapping I
did (which I seriously doubt) or switching back and forth between SRM
and AlphaBIOS somehow corrupted part of the card's firmware.

Any advice is greatly appreciated. Thanks.

Peter
--
www.alphalinux.org
Peter Petrakis          Warrior/Engineer       ppetrakis@alphalinux.org
"Oh my God! They killed Xena! You bastards!!" 
"<BLAM!!> Who the hell are you!? Name's Ash <click clock> Housewares..."



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []