[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Help me with RH 7.2 insatllation on 164SX :(



On Mon, Aug 26, 2002 at 07:49:01PM -0700, Ram Viswanadha wrote:
>
> If you are one of those mortals who have prefer AlphaBios to SRM, this
> information may be useful:

SRM would make your problems go away, you know... ;-}

> Configuration of my system
> 164SX M.B
> 21164 533 MHz CPU
> 640 MB RAM
> AHA2940 U2W SCSI card
> Matrox Millenium II video card
> 8 Gig Hitachi SCSI drive
> 12 gig Seagate IDE drive
> AlphBios 5.70
> 
> Upgraded to Milo-2.2-18 binary from Milo Version 2.0.5.3 (I think). Milo
> hangs while loading AHA2940 dirvers. So downgraded to Milo-2.2-17 works fine
> and boots vmlinux.gz from CD-ROM.

Where did you get that 2.2.-18 MILO for SX? I put one here:

	ftp://ftp.digital.com/pub/Digital/Linux-Alpha/TESTING/sx-milo

that may help with some of your problems.

> The installation documentation points to firmware upgrade of AlphaBios.
> Downloaded the sx164_v5_8.exe, renamed it to fwupdate.exe on a FAT formatted
> floppy, powered on the system and selected AlphaBios upgrade from the Bios
> menu. AlphaBios loads the image from floppy but hangs. Same result with
> sx164_v5_7.exe
> So had to make good with whatever AlphaBios (version 5.70) I had.

I think there perhaps was a 5.71, but I may be mis-remembering.

Regardless, I don't think the install should hang like that... :-(

> The installation completes fine. Post-Installation configuration crashes.
> 
> Reboot. Milo does not see any files listed in the partitions..!!!!!
> Does not want to boot from the IDE.

RH 7.2 install into partitions bigger than ~2GB will use a blocksize
other than 1K (as Michal said), which will cause problems with older
MILOs which ONLY handle 1K blocksize (the one aboive will work fine).

Workaround, again as Michal said, is a small /boot partition into
which the kernels/initrds are placed.

> So as a last resort did
> 
> boot hdd:kernels/vmlinux.gz root=/dev/hda3
> 
> The boot completes fine and I can see all files in both IDE and SCSI drives.

So it boots fine from IDE CDROM - blocksize of ISO FS is 1K... ;-}

> So concluded that the problem may be with Milo... installed the source rpm
> of 2.4.9 stock RedHat 7.2 kernel, configured built since Milo wants it.
> Try to compile Milo make fails, it turns out the super_block struct in fs.c
> of linux/fs has changed.

Interesting; you tried to build against a 2.4.9 kernel? I think someone
has been trying that, but I didn't think it was working/available yet...

> I am out of  ideas. Can anyone please help me get up and running.

Become one of the larger group of "mortals" and go to SRM... :-)

Seriously, if, after trying that new MILO you still have problems with
hanging during Adaptec probe, you'll either have to stick with the
older MILO or go to SRM, IMHO.

Sorry, I don't have, or test, options which were not commmonly sold or
added into the older boxes like LX and SX when they were new, and U2W
controllers are among them... :-\

 --Jay++

-----------------------------------------------------------------------------
Jay A Estabrook                            HPTC - LINUX support
Hewlett-Packard Company - MRO1-2/K15       (508) 467-2080
200 Forest Street, Marlboro MA 01752       Jay.Estabrook@hp.com
-----------------------------------------------------------------------------





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index] []