[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Cluster-devel] cluster/fence/agents/drac fence_drac.pl



CVSROOT:	/cvs/cluster
Module name:	cluster
Branch: 	RHEL4
Changes by:	jparsons sourceware org	2006-09-06 15:32:37

Modified files:
	fence/agents/drac: fence_drac.pl 

Log message:
	Support for DRAC ERA

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/cluster/fence/agents/drac/fence_drac.pl.diff?cvsroot=cluster&only_with_tag=RHEL4&r1=1.3.2.4&r2=1.3.2.5

--- cluster/fence/agents/drac/fence_drac.pl	2006/02/15 12:54:30	1.3.2.4
+++ cluster/fence/agents/drac/fence_drac.pl	2006/09/06 15:32:36	1.3.2.5
@@ -17,6 +17,8 @@
 #  Model 		DRAC Version	Firmware
 #  -------------------	--------------	----------------------
 #  PowerEdge 750	DRAC III/XT	3.20 (Build 10.25)
+#  Dell Remote Access Controller - ERA and DRAC III/XT, v.3.20, A00
+#  
 #  PowerEdge 1855	DRAC/MC		1.1  (Build 03.03)
 #  PowerEdge 1855	DRAC/MC		1.2  (Build 03.03)
 #  PowerEdge 1850	DRAC 4/I	1.35 (Build 09.27)
@@ -130,6 +132,10 @@
 		fail "failed: telnet failed: ". $t->errmsg."\n" ;
 
 	# Determine DRAC version
+  if (/Dell Embedded Remote Access Controller \(ERA\)\nFirmware Version/m)
+  {
+    $drac_version = $DRAC_VERSION_III_XT;
+  } else {
 	if (/.*\((DRAC[^)]*)\)/m)
 	{
 		print "detected drac version '$1'\n" if $verbose;
@@ -144,6 +150,7 @@
 		print "WARNING: unable to detect DRAC version '$_'\n";
 		$drac_version = $DRAC_VERSION_UNKNOWN;
 	}
+  }
 
 	# Setup prompt
 	if ($drac_version =~ /$DRAC_VERSION_III_XT/)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]