[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Cluster-devel] Problems with recent Makefile changes



Hi Fabio,

I did find a couple problems with your new changes to the Makefiles
for cluster suite.  The first problem is that the gfs2 userland tools
don't have a dependency set for ../libgfs2/libgfs2.a.  So if you
change a function in libgfs2 and recompile, the userland tools never
know to link in the modified libgfs2.a library.

The second problem I ran into yesterday. Basically, I compiled a gfs2 userland tool and got a compiler error. I fixed the error
and replaced the file.  However, my second compile--which should have
been successful--failed with some odd error message. After I did "make clean" and "make" again, it worked. I should have gotten more info at the time, but unfortunately, I didn't because I was in a hurry. If I run across this again, I'll try to get more information about
what's happening.

Regards,

Bob Peterson
Red Hat Cluster Suite


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]