[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Cluster-devel] cluster/fence/agents/manual fence_ack_manual.sh



CVSROOT:	/cvs/cluster
Module name:	cluster
Changes by:	lhh sourceware org	2007-05-14 16:33:53

Modified files:
	fence/agents/manual: fence_ack_manual.sh 

Log message:
	Make manual fencing's command line parser backward compatible; per dct

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/cluster/fence/agents/manual/fence_ack_manual.sh.diff?cvsroot=cluster&r1=1.1&r2=1.2

--- cluster/fence/agents/manual/fence_ack_manual.sh	2007/01/22 23:16:12	1.1
+++ cluster/fence/agents/manual/fence_ack_manual.sh	2007/05/14 16:33:53	1.2
@@ -1,7 +1,20 @@
 #!/bin/bash
+#
+# Dummy fence_ack_manual which uses the fenced manual override
+# socket to communicate.
+#
+
+if [ "$1" = "-n" ]; then
+	shift
+fi
 
 if [ -z "$1" ]; then
-	echo "usage: $0 <nodename>"
+	echo "usage:"
+        echo " 	$0 <nodename>"
+        echo " 	$0 -n <nodename>"
+	echo 
+	echo "The -n flag exists to preserve compatibility with previous "
+	echo "releases of $0, and is no longer required."
 	exit 1
 fi
 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]