[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Cluster-devel] [PATCH] avoid configure failure with F10's 2.6.27.21 kernel headers



Hi Jim,


On Fri, 2009-06-19 at 20:26 +0200, Jim Meyering wrote:
> Without the patch below, ./configure would fail like this on Fedora 10:
> 
>   checking linux/dlm_plock.h usability... no
>   checking linux/dlm_plock.h presence... yes
>   configure: WARNING: linux/dlm_plock.h: present but cannot be compiled
>   configure: WARNING: linux/dlm_plock.h:     check for missing prerequisite headers?
>   configure: WARNING: linux/dlm_plock.h: see the Autoconf documentation
>   configure: WARNING: linux/dlm_plock.h:     section "Present But Cannot Be Compiled"
>   configure: WARNING: linux/dlm_plock.h: proceeding with the compiler's result
>   configure: WARNING:     ## --------------------------------------- ##
>   configure: WARNING:     ## Report this to linux-cluster redhat com ##
>   configure: WARNING:     ## --------------------------------------- ##
>   checking for linux/dlm_plock.h... no
>   configure: error: Unable to find dlm kernel headers.
>   Make sure to install kernel headers 2.6.26 (or higher) or use --with-kernel=path
>   configure option to point to the kernel source.
>   [Exit 1]
> 
> and config.log showed the problem:
> 
>   In file included from conftest.c:79:0:
>   /usr/include/linux/dlm_plock.h:25:2: error: expected specifier-qualifier-list before '__u32'
> 
> Here's the patch:

I haven't tested this patch directly but it looks good to go in.

gfs2-utils.git might benefit for a similar change, let me know if you
have time to do go for it, or I'll do it at the next round of merges.

Thanks
Fabio


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]