[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Cluster-devel] conga/luci/init.d luci



CVSROOT:	/cvs/cluster
Module name:	conga
Branch: 	RHEL5
Changes by:	rmccabe sourceware org	2010-02-04 23:36:35

Modified files:
	luci/init.d    : luci 

Log message:
	conga: fix bz469881
	
	Give luci more time to start up. This should fix problems with the luci init script when luci is running on a heavily loaded (or just very slow) machine.

Patches:
http://sourceware.org/cgi-bin/cvsweb.cgi/conga/luci/init.d/luci.diff?cvsroot=cluster&only_with_tag=RHEL5&r1=1.11.2.5&r2=1.11.2.6

--- conga/luci/init.d/luci	2008/04/11 06:50:32	1.11.2.5
+++ conga/luci/init.d/luci	2010/02/04 23:36:34	1.11.2.6
@@ -138,7 +138,7 @@
 	fi
 
 	stop_luci
-	max_wait=10
+	max_wait=25
 	cur_wait=0
 	while [ $cur_wait -lt $max_wait ]; do
 		sleep 1
@@ -150,7 +150,11 @@
 	done
 
 	if [ $? -ne 0 ]; then
-		errmsg='Failed to stop luci'
+		if [ $cur_wait -eq $max_wait ]; then
+			errmsg="Luci did not stop after $max_wait seconds."
+		else
+			errmsg='Failed to stop luci'
+		fi
 		return 1
 	fi
 	return 0
@@ -170,7 +174,7 @@
 	sh $LUCID >&/dev/null &
 
 	cur_wait=0
-	max_wait=10
+	max_wait=25
 	luci_running
 	ret=$?
 	while [ $ret -ne 1 ] && [ $cur_wait -lt $max_wait ]; do
@@ -181,7 +185,11 @@
 	done
 
 	if [ $ret -ne 1 ]; then
-		errmsg='An error occurred while starting luci'
+		if [ $cur_wait -eq $max_wait ]; then
+			errmsg="Luci did not start after $max_wait seconds."
+		else
+			errmsg='An error occurred while starting luci'
+		fi
 		stop_luci
 		return 1
 	fi


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]