[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Cluster-devel] [PATCH] mkfs: Remove duplicated code from verify_bsize()

My apologies for my delay, I was on PTO.

> are_you_sure() doesn't really belong in libgfs2 because it's user
> interface code and it has exit() calls (via die()). You might want
> to read bz408631 to see where libgfs2 is heading.
Gotcha will look.
> >+/*Function prototypes*/
> Minor point, but I personally dislike comments like this. Everyone
> knows what a function prototype looks like :)
Indeed. I added it mainly to "make it clear" but I agree in do not add
this comment.

> I'm not sure that it is worth using are_you_sure() here, as it opens
> the device again and calls check_dev_content() (which calls pipe()
> and then fork() ...), which is a lot more overhead than the few
> lines that you're removing here. Perhaps you could change
> are_you_sure to be more generic and move the checking into a
> separate function?
Looks like both (Steve and Andy) agrees to remove open() call from
are_you_sure() function, so, looks that's the best way to fix this up
and maybe as Andy suggestion set up another function to test device open
if necessary.

My concern here btw, is if there is any problem in add the function prototype 
to the beginning of the file.

What you guys think?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]