[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[Crash-utility] [PATCH 00/12] make crash-trace-command compatible for many different kernels



The crash tools and the extensions must work for all various kernels.
The trace.so is for rhel6 kernel(2.6.32) original, it is outdated,
these patches fix it. Now it works for all 2.6.xx kernels(including
2.6.38-RC1) which have ftrace.

The major difference between current kernel and old kernel is that,
struct ftrace_event_class was introduced to ftrace
as Jeff noted. So these patches add a lot of
struct ftrace_event_class related code, thanks to Jeff.

Also thanks to Dave for many suggestions.

All the code were applied to:
git://github.com/laijs/tracing-extension-module-for-crash.git

Thanks a lot.
Lai


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]